OWB. Correspondencias: linea de ejecucion

Ver el tema anterior Ver el tema siguiente Ir abajo

OWB. Correspondencias: linea de ejecucion

Mensaje  timotipol el Miér 11 Ago 2010, 10:52

Hola,

tengo un problema/duda.

tengo un mapeo que lee de un tabla origen y la compara con una DESTINO, hace un minus para dar las altas.
Me carga los nuevos registros como altas en DESTINO. de ahí lo paso a un JOIN para recuperar de ORIGEN una fecha que no me hace falta en DESTINO y meto todo en otra tabla HISTORICO.

Pues mi duda es ¿por qué cuando lo INICIO (todo de forma automatica) sólo carga los datos en la tabla DESTINO y no en la la de HISTORICO, pero cuando lo hago paso a paso con el Debug, me carga bien en las dos tablas.??

Creo que el OWB hace alguna secuencia que desconozco.

Gracias
fdo Tim

timotipol

Cantidad de envíos : 9
Localización : timotipol
Fecha de inscripción : 11/08/2010

Ver perfil de usuario

Volver arriba Ir abajo

Usar varios mapeos

Mensaje  timotipol el Mar 17 Ago 2010, 09:30

Hola,
tras mil intentos e intantar comprender el funcionamiento de esta tremenda aplicación he llegado a la conclusion de:
1.- es mejor hacer 5 mapeos/correspondecias pequeñas y lanzarlas una a una que una grande.
2.- en cuanto al problema, una vez que acababa de cargar en DESTINO, antes de cargar en HISTORICO hace el Join, qué pasa, que volvía a iniciar el proceso desde el MINUS para recuperar los datos para el JOIN, y ese MInus la segunda vez estaba vacio. Con el DEBUGGER no reinicia el proceso, por eso lo hacía bien. bueno creo que esto es lo que pasa.

de todas formas, ya he solucionado el problema con varias correspondencias.
fdo Tim

timotipol

Cantidad de envíos : 9
Localización : timotipol
Fecha de inscripción : 11/08/2010

Ver perfil de usuario

Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.