Navegar a otro informe con filtrado de datos

Ver el tema anterior Ver el tema siguiente Ir abajo

Navegar a otro informe con filtrado de datos

Mensaje  equipoBI el Vie 03 Abr 2009, 16:05

Hola a todos,

Me está pasando una cosa muy rara que nunca me ha pasado y que hemos hecho miles de veces correctamente, os cuento a ver si alguien me puede ayudar porque se me acaban los recursos xD.

Tengo un informe en OBI de tipo tabla el cual el último campo tiene activada la navegación a otro informe de más detalle, en el informe detalle tengo puesto el campo clave como se solicita pero a la hora de pinchar y mostrarlo no me acota los datos saliendome todo.

Esto lo hemos hecho muchas veces y siempre funcionó correctamente, he comprobado el modelo de negocio y está igual que las partes que funcionan y he mirado la consulta que genera y no está incluyendo el filtro por la clave en la misma.

¿Se os ocurre algo?

Muchas gracias.

Saludos.

Equipo BI

equipoBI

Cantidad de envíos : 128
Fecha de inscripción : 24/02/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Navegar a otro informe con filtrado de datos

Mensaje  bvillamor el Dom 05 Abr 2009, 19:31

Hola,
en una ocasión me pasó algo parecido entre un filtro de cuadro de mando y una consulta. El problema estaba en el nombre del campo, que no era idéntico en los dos sitios.
La consulta había sido hecha cuando el campo tenía un nombre en la capa de presentación y el filtro cuando tenía otro. Como se había creado un alias ambos funcionaban bien de forma independiente, pero a la hora de pasar los valores del filtro a la consulta, si el nombre no era exactamente el mismo, no se aplicaba el filtro.

Espero que os sirva de algo.

Begoña.

Adiante

bvillamor

Cantidad de envíos : 388
Localización : Madrid
Fecha de inscripción : 18/02/2009

Ver perfil de usuario http://www.adiante.es

Volver arriba Ir abajo

Re: Navegar a otro informe con filtrado de datos

Mensaje  equipoBI el Mar 07 Abr 2009, 13:13

Hola de nuevo,

Eso que me comentas ya lo había probado pero de todas maneras he borrado los campos y me he asegurado que se llamen igual y sigue sin hacer ni caso.

Es muy raro, esto no nos había pasado nunca ya que tenemos varios informes de este tipo que muestran detalle y están montados de varias maneras, con medidas sin medidas, siendo las tablas detalle de la original siendo una dimensión y siempre funciono sin problema.

Os dais cuenta que exista alguna restricción que se me esté escapando de hacer y por eso no tira?

Muchas gracias.

Saludos.

Equipo BI

equipoBI

Cantidad de envíos : 128
Fecha de inscripción : 24/02/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Navegar a otro informe con filtrado de datos

Mensaje  Contenido patrocinado Hoy a las 14:51


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.