Problema con un reporte

Ver el tema anterior Ver el tema siguiente Ir abajo

Problema con un reporte

Mensaje  CCM el Vie 05 Ago 2011, 23:00

Hola amigos.

hace tiempo que tengo publicado un reporte, el cual no había presentado problemas, pero a medida que han pasado los meses los datos han ido incrementando y actualmente se me presento un error con el tablespace TEMP, lo que hicimos fue expandir este tablespace pero aun asi hay algunas navegaciones que no funcionan.

El problema lo tengo identificado, lo que sucede es que existen 2 areas tematicas y necesito capturar algunos datos del primer reporte publicado el cual nace del area tematica 1, como por ejemplo capturo el año, el periodo y el numero de cuenta para poder hacer la navegacion, por lo tanto en el reporte n 2 la query que se genera es enorme ya que normalmente seria algo asi

periodo in (ene-11, feb-11,mar-11 ... ) and año = 2011 and cuenta 'xx'

pero en presentation services utilizo un filtro avanzado , filtro basado en los resultados de otra solicitud para esos 3 campos, por lo tanto mi codigo sql crece enormemente, ya que realiza muchos sub select incluyendo campos innecesarios.

Si alguien se le ha presentado antes este problema por favor orientarme como lo soluciono, ya que al ser 2 areas tematicas diferentes al poner filtro se solicita no me toma el valor del reporte 1.

Gracias.

CCM

Cantidad de envíos : 35
Localización : chile
Fecha de inscripción : 19/07/2010

Ver perfil de usuario

Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.