Problemas con Modelo Copo de Nieve...

Ver el tema anterior Ver el tema siguiente Ir abajo

Problemas con Modelo Copo de Nieve...

Mensaje  rvalenzuela el Mar 04 Oct 2011, 17:17

Buena tarde amigos, necesito pedir su valiosa colaboración.

Tengo un modelo Copo de Nieve, es decir, tengo una fact que se relaciona con sus dimensiones y a la vez, una de esas dimensiones se relaciona con otra estructura.

La dimensión que se relaciona con la FACT se llama CLIENTES, y la dimansión de CLIENTES se relaciona con otras estructuras que tienen valores como: estado del cliente, tipo de identificación, estado civil. Lo hice así porque son muchas relaciones de este tipo que tiene la dimensión de CLIENTES y no quería llevarme a esta dimensión todos esos campos descriptivos.

El problema es el siguiente, cuando modelo la capa semántica en la herramienta Administration de OBIEE, puedo crear sin problema todas las relaciones, es decir, la relación entre la FACT y la dimensión de CLIENTES, pero cuando creo la relacion entre la dimensión de CLIENTES y las otras estructuras que hacen el copo de nieve, me sale el siguiente error [39008] Logical dimension table ESTADO ASESOR has a source V_ESTADO_ASESOR that does not join to any fact source.

En ANSWERS al tratar de ejecutar la consulta sale el siguiente mensaje: Estado: HY000. Código: 10058. [NQODBC] [SQL_STATE: HY000] [nQSError: 10058] A general error has occurred. [nQSError: 14065] Illegal cross join within the same dimension caused by incorrect subject area setup: [ DV_D_ESTRUCTURA_COMERCIAL T103] with [ V_ESTADO_ASESOR T5590] (HY000)

Agradezco la ayuda de ustedes para poder resolver este inconveniente.

Muchas Gracias.

rvalenzuela

Cantidad de envíos : 49
Edad : 44
Localización : Bogotá D.C. - Colombia
Fecha de inscripción : 17/07/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Problemas con Modelo Copo de Nieve...

Mensaje  D. Campo el Mar 04 Oct 2011, 17:56

Que version de BI estas usando?

D. Campo

Cantidad de envíos : 101
Localización : Caracas
Fecha de inscripción : 13/05/2009

Ver perfil de usuario

Volver arriba Ir abajo

Problemas con Modelo Copo de Nieve...

Mensaje  rvalenzuela el Mar 04 Oct 2011, 18:37

Estoy usando la versión 10.1.3.4.0

rvalenzuela

Cantidad de envíos : 49
Edad : 44
Localización : Bogotá D.C. - Colombia
Fecha de inscripción : 17/07/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Problemas con Modelo Copo de Nieve...

Mensaje  bvillamor el Miér 02 Nov 2011, 22:35

Hola,
no sé si a estas alturas ya habrás conseguido resolver tu problema pero por si acaso te cuento. En la capa de negocio de OBI debes tener una estrella pura, aunque en la capa física sea un copo de nieve. Esto se consigue añadiendo varias tablas al Logical Table Source (LTS) de la dimensión. En tu caso, en la capa de negocio debes tener una tabla lógica para la dimensión de clientes, una vez la tengas entras en la LTS y añades las tablas que se relacionan con clientes y tienen el resto de los atributos. De esta forma OBI entiende que ese conjunto de tablas funciona como un único objeto y dejará de sacar los errores que comentas.

Saludos,

_________________
Begoña Villamor
Oracle Fusion Middleware 11g Business Intelligence Foundation Certified Implementation Specialist

Adiante
http://www.adiante.es

bvillamor

Cantidad de envíos : 388
Localización : Madrid
Fecha de inscripción : 18/02/2009

Ver perfil de usuario http://www.adiante.es

Volver arriba Ir abajo

Re: Problemas con Modelo Copo de Nieve...

Mensaje  rvalenzuela el Miér 02 Nov 2011, 23:14

Begoña, muy buenas tardes y muchas gracias por tu respuesta.

Pues te cuento que hace algunos días haciendo una pruebita aquí y otra pruebita allá, me di cuenta que era necesario hacer lo que tu me dices, que toca hacer una estrellita con la dimensión de clientes como si fuera el cubo y con las dimensiones propias de clientes.

Pero sabes, tu respuesta me deja tranquilo de que esa es la forma de hacerlo, lo digo porque se que tienes una basta experiencia en la herramienta, y que me confirmes la forma de hacerlo me da la seguridad de que está bien.

Mil y mil gracias como siempre por tu constante colaboración.

Un abrazo,


Raúl Valenzuela
Bogotá - Colombia.

rvalenzuela

Cantidad de envíos : 49
Edad : 44
Localización : Bogotá D.C. - Colombia
Fecha de inscripción : 17/07/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Problemas con Modelo Copo de Nieve...

Mensaje  Contenido patrocinado Hoy a las 20:42


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.