Formato condicional en mapas no se muestra en iPad

Ver el tema anterior Ver el tema siguiente Ir abajo

Formato condicional en mapas no se muestra en iPad

Mensaje  equipoBI el Vie 07 Dic 2012, 12:03

Hola a todos,

Cuando accedemos a través de la app para iPad a un cuadro de mando que tiene un mapa con formato condicional (de relleno de color), los colores no aparecen, sino que se muestran interrogaciones (?). La leyenda sí que se muestra correctamente y podemos interactuar con el mapa a través de Action Links, pero el mapa no se "colorea".

Estamos utilizando la versión 11.1.6.2.

¿Alguien sabe si esto es un bug y si hay manera de solucionarlo?

Saludos

equipoBI

Cantidad de envíos : 128
Fecha de inscripción : 24/02/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Formato condicional en mapas no se muestra en iPad

Mensaje  bvillamor el Vie 07 Dic 2012, 13:55

Hola,
cuando dices que tienes formato condicional en el mapa, a qué te refieres, ¿a que tienes una capa de datos de tipo relleno de color o a un formato condicional de los que se ponen en Criterios?
Si es una capa de datos en el mapa no debería darte ningún problema, eso sí, asegúrate de que tienes actualizada la versión de la aplicación de ipad, la cambiaron para ajustarse a la versión 11.1.1.6.2

Saludos,

_________________
Begoña Villamor
Oracle Fusion Middleware 11g Business Intelligence Foundation Certified Implementation Specialist

Adiante
http://www.adiante.es

bvillamor

Cantidad de envíos : 388
Localización : Madrid
Fecha de inscripción : 18/02/2009

Ver perfil de usuario http://www.adiante.es

Volver arriba Ir abajo

Re: Formato condicional en mapas no se muestra en iPad

Mensaje  equipoBI el Lun 10 Dic 2012, 15:17

Hola Begoña,

Me refiero a una capa de datos de relleno de color, y ni con la versión 11.1.1.5.0 de la aplicación para iPad ni con la versión Oracle BI HD se muestran los colores, siguen apareciendo las interrogaciones. Da igual lo que escojamos para mostrar en la capa (relleno de color, gráfico, imagen, forma variable...), que se siguen mostrando las interrogaciones.

Lo curioso es que sí que es capaz de detectar dónde tiene que mostrar cada cosa. Estamos usando un mapa de España y las interrogaciones aparecen justo en las CCAA para las que tenemos datos del indicador.

Saludos.

equipoBI

Cantidad de envíos : 128
Fecha de inscripción : 24/02/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Formato condicional en mapas no se muestra en iPad

Mensaje  bvillamor el Mar 11 Dic 2012, 17:32

Hola,
resulta que mapviewer genera la url de determinadas imágenes de mapas con el nombre o dirección del host desde el que se hace el primer acceso. Si luego nos conectamos desde otra red, las imágenes pueden estar inaccesibles. Ejemplo:

  • tenemos un servidor OBI en la máquina srvobi de nuestra red local pero también tiene un acceso a través de una ip pública
  • reiniciamos mapviewer
  • accedemos desde la red local a un informe con mapas que tenga una capa de relleno de color
  • mapviewer genera las imágenes con la url http://srvobi:7001/mapviewer/images/img....
  • ahora desde otra red, una conexión 3G por ejemplo, accedemos al mismo informe o a otro que también tenga mapas
  • OBI generará las imágenes de mapas con la misma url de antes y, si esta ulr no está accesible, no veremos las imágenes

La solución sería que mapviewer generase todas las imágenes con una ruta relativa pero, como no lo hace, hay una opción de configuración que en algunos casos puede servirnos.

En el archivo de configuración de mapviewer hay una sección llamada "save_images_at". Por defecto está comentada y ello supone que la url de las imágenes es http://%HOSTNAME%:%PORT%/mapviewer/images. Si el primer acceso se hace desde una red visible desde todos los puntos, tenemos suerte. Si se hace desde la red local, dejarán de verse las imágenes de mapas cuando nos conectemos desde el exterior.
Podemos modificar el parámetro url para que siempre utilice la ip pública o el nombre de nuestro servidor, por ejemplo:

Código:

<save_images_at 
            file_prefix="omsmap"
            url="http://mi_nombre_publico:7001/mapviewer/images"
 />

Saludos,

_________________
Begoña Villamor
Oracle Fusion Middleware 11g Business Intelligence Foundation Certified Implementation Specialist

Adiante
http://www.adiante.es

bvillamor

Cantidad de envíos : 388
Localización : Madrid
Fecha de inscripción : 18/02/2009

Ver perfil de usuario http://www.adiante.es

Volver arriba Ir abajo

Re: Formato condicional en mapas no se muestra en iPad

Mensaje  equipoBI el Miér 12 Dic 2012, 12:43

Gracias Begoña,

Así ya funciona perfectamente.

Saludos

equipoBI

Cantidad de envíos : 128
Fecha de inscripción : 24/02/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Formato condicional en mapas no se muestra en iPad

Mensaje  Contenido patrocinado Hoy a las 01:17


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.